Amyuni and Windows Vista

The Amyuni PDF Converter is our Printer Driver that enables you to convert any documents to PDF format. If you have any questions about installing and using the Amyuni PDF Converter please post them here.

Amyuni and Windows Vista

Postby Robert on Tue Jun 20 2006

Hello,

Has anybody looked into Amyuni PDF converter and Windows Vista yet ? I've installed the Beta 2 version of Vista and tried to install Amyuni PDF converter 2.10i and was unable to. I know this is early on for tests on Vista but it would be nice to know when a Vista compatible version of Amyuni will be available or if it is being looked into.

Regards,

Robert
Robert
 
Posts: 21
Joined: Tue Nov 19 2002
Location: Quebec City

Amyuni and Windows Vista

Postby Robert on Wed Jun 21 2006

Hello,

Here's the message that Vista displays when I execute Install.exe on Vista.

"Windows can't install the Amyuni PDF converter 2.10 kernel-mode print driver. To obtain a driver that is compatible with the version of Windows you are running, contact the manufacturer." <Ok>

I took a look at the log that was generated by Install.exe and the following error code was present.

Installing printer driver
Error code 1930
The printer driver is not compatible with a policy enabled on your computer that blocks NT 4.0 drivers

I found several posts on this forum concerning this error which mentionned that we need to deactivate the "Enable installation of Kernel mode printer driver" security policy. But these posts pertain to Windows XP and 2003.

Will I have to change my version of PDF Converter to solve this problem ? Is it possible to disable to policy attribute programatically before calling Install.exe from my software installation kit ?

Regards,

Robert[/img]
Robert
 
Posts: 21
Joined: Tue Nov 19 2002
Location: Quebec City

Postby Joan on Sun Jun 25 2006

Hello,

I suggest that you try our new version 2.50 on Vista, I try myself on Vista Beta 1 and it is working properly. Our testing team is testing it on Vista Beta 2 but i don't have the test results yet.

Hope this helps.
Last edited by Joan on Tue Dec 26 2006, edited 1 time in total.
Joan
Amyuni Team
 
Posts: 2799
Joined: Wed Sep 11 2002

Amyuni and Windows Vista

Postby Robert on Tue Jul 11 2006

Hi Joan,

I've finally got the 2.50b version of PDF Converter and tested it on Vista.

I have one question though. I deploy my apps that use PDF Converter on all flavors of Windows except Win95 and I was looking at the deployment requirements in the Introduction section of the Common driver Interface 250 document and something isn't right in that document.

It mentions that for WinNT 4 we must deploy the acfpdf.dll and acfpdfnt.dll files but I cannot find those files anywhere.

My developpement machine is WinXP and I've installed PDF Converter 2.50 on it. I looked in the directory where it is installed and those files are not present.

Is the document wrong or did something go wrong with the installation ?

Regards,

Robert
Robert
 
Posts: 21
Joined: Tue Nov 19 2002
Location: Quebec City

Postby Joan on Tue Jul 11 2006

Hello,

These files are not distributed anymore with the installer.

We send them to our customers directly.

You can send an e-mail to support@amyuni.com mentioning the files you need and your licensee name and we will send you these files by e-mail.

Regards,
Joan
Amyuni Team
 
Posts: 2799
Joined: Wed Sep 11 2002

Postby POZ.James on Tue Dec 19 2006

Hello AmyUni team,

I wonder if you can help... We have been experiencing similar problems to the above. Specifically "The printer driver is not compatible with a policy enabled on your computer that blocks NT 4.0 drivers" - on Windows VISTA and are unable to find a solution or work around.

We are using the following versions:-
    PDF Convertor 2.10i
    PDF Creator 1.50i

I believe it is converter 2.10i that is causing the problem, but having read up on this on your forums it appears that this uses user-mode (rather than kernal-mode) so shouldn't be a problem anyway??

Can you offer any assistance, or must we upgrade our license to the 2.50+ version ?
(We would prefer to find a solution which does not require an upgrade because of the delays which will be caused due to change control)

Thank-you,
James.
POZ.James
 
Posts: 8
Joined: Mon Dec 18 2006

Postby Joan on Tue Dec 26 2006

Hello,

Under Vista you need to have PDF Converter 2.50 and above.

Please downlaod the latest version from our site and try it.

Season's Greetings
Joan
Amyuni Team
 
Posts: 2799
Joined: Wed Sep 11 2002

Postby ASRoden on Thu Jan 04 2007

On a related note. We included a bunch of Vista SDK headers in our project and now the ActiveX control throws an exception. I am using an ATL window class to wrap the amyuni control. Has onyone else seen this? I am tryin to narrow it down to a particular header but there are about 1000 and they are all interconnected. Fun!
ASRoden
 
Posts: 34
Joined: Thu Jun 15 2006
Location: Auburn, NY USA

Postby Joan on Tue Jan 09 2007

Hello James,

This issue is not directly related to the above post.

I suggest that you sent this question to support@amyuni.com to check it. I don't beleive there should be any conflict between the activeX and the header files but i can't confirm because I don't have your appliation.

Which version of the PDF Converter are you using?
Joan
Amyuni Team
 
Posts: 2799
Joined: Wed Sep 11 2002

Postby bytebloc on Fri Aug 10 2007

Greetings,

We are using Amyuni Document Converter version 2.51-d, and it installs and runs without problem on our Vista test bed.

We've just released the Vista version of our program and already have a report of this message during install on a Vista machine:

Windows can't install the Amyuni Document Converter 2.51 kernel-mode print driver. To obtain a driver that is compatible with the version of Windows you are running, contact the manufacturer.


We had the user run the install in its debug mode (which we have show the Amyuni install interface). It reports:
-------
Installing Amyuni PDF printer driver
Error Code: 1930
The printer driver is not compatible with a policy enabled... (the only text visible on the screen shot sent by the user)
-------


Vista install has gone OK for at least one other customer.

I'd thought that Amyuni Document Converter 2.51 avoided the kernel-mode installation problem in Vista. Any idea why this one user is getting that message? Any solution?

Thanks!
bytebloc
 
Posts: 5
Joined: Mon Jul 17 2006

Postby Joan on Mon Aug 13 2007

Hello,

Amyuni Document Converter 2.51-d uses user mode driver and not kernel mode.

I suspect that on the machine where the installation is failing there is an old version of the driver stuck there and it is being installed.

I suggest to make a search for the following files:
acfpdf*.*
cdintf*.*
and check that there is only one version of these files on the system and this is the 2.51-d version, unless the user needs to have an older version of the Document Converter on the system to run with another application.

Hope this helps.
Joan
Amyuni Team
 
Posts: 2799
Joined: Wed Sep 11 2002

Postby bytebloc on Thu Aug 16 2007

We have not heard back yet from the original user with the problem, but now have a second user with a similar problem, also on Vista. They have the "latest version of Quicken" installed and confirmed that it uses Amyuni drivers with version 2.50. I would not expect that to cause the reported problem with the "kernel mode" error, but let us know. Any further suggestions at this point?
bytebloc
 
Posts: 5
Joined: Mon Jul 17 2006

Postby Jose on Fri Aug 17 2007

Hello,

I believe that that the latest version of Quicken actually installs version 2.50e-3 of our PDF Converter product. This version of the PDF Converter will not install on windows vista or on windows XP/2003 64bit editions.

Hope this helps?
Jose
Amyuni Team
 
Posts: 460
Joined: Tue Oct 01 2002

Postby bytebloc on Fri Aug 17 2007

Hello again,

The support site for Quicken contains instructions for resolving "conflicts between the Quicken PDF printer and other printers or drivers installed on the computer" at:

https://quicken.custhelp.com/cgi-bin/quicken.cfg/php/enduser/std_adp.php?p_faqid=5525&p_topview=1

This includes a link to the download of an inf file at:

https://quicken.custhelp.com/cgi-bin/quicken.cfg/php/enduser/fattach_get.php?p_sid=rVNmQrji&p_accessibility=0&p_tbl=9&p_id=5525&p_created=1173117569&p_olh=0

that apparently installs a printer based on Amyuni version 2.51 Document Converter drivers using the Windows "Add Printer" wizard. If it performs as advertised, it could provide a solution for us. I do not understand all of the sections of the inf file; do you have more information on using this method to install an Amyuni PDF printer?

Also, reviewing our installation I note that these files in the list of distributable files are shown in the Amyuni Document Converter manual:
Windows XP/2003 64-bits, IA 64 based: acfpdfuia64.dll, acfpdfuiia64.dll

are not included in the files that we received from Amyuni with version 2.51-d of the Document Converter, though the mouseover on this in the manual states that it was new in 2.50e. Where can these be obtained, and could that be part of the problem?

Looking forward to any further information you can provide. Hopefully we're getting close to a solution!

P.S. As a point of interest, the information that PDF Converter 2.50 is not compatible with Vista conflicts with a previous statement in this thread (see Amyuni Team comment by Joan dated Jan 24, 2007 -- "Under Vista you need to have PDF Converter 2.50 and above"). Has this changed?
bytebloc
 
Posts: 5
Joined: Mon Jul 17 2006

Postby Joan on Mon Aug 20 2007

Hello,

Actually support for vista is only possible with versions 2.50g-4 and higher of the PDF Converter.

Versions 2.1, 2.0 and 1.5 do not support Vista or 64-bits OS.

The inf file available in the link installs a PDF Printer called "Quicken PDF Printer" version 2.51 on Windows XP and Vista 32-bits. However for the inf to install version 2.51 you need to make sure that the dlls of version 2.51 are in the same folder of the inf, if older dlls are there than older version will be installed.

There are different ways to install the printer driver, one of them is through the Add Printer wizard using an inf file, another way is to use our Install.exe or setup.exe that you receive with the product.

This inf file will not install the driver on 64-bits, to install the driver on 64-bits you need the 64-bits dlls, a 64-bits license and an inf for 64-bits installation (if you want to install using the inf file).

The files you mentioned below are not distributed with the driver, you can download them from: www.amyuni.com/downloads/legacy_drivers.zip

Hope this helps.
Joan
Amyuni Team
 
Posts: 2799
Joined: Wed Sep 11 2002


Return to Amyuni PDF Converter (PDF Printer Driver)

Who is online

Users browsing this forum: Google [Bot] and 3 guests